Mybook World and Mybook Live Features Packs

Great Features for your Mybook in few clicks

  • Increase font size
  • Default font size
  • Decrease font size
Home Mybook World White Light Feature Pack Installer FeaturePacks Manager installation

FeaturePacks Manager installation

E-mail Print PDF

The FeaturePacks Manager will add an additional web interface to the standard Western Digital Interface.

This new administration interface will allow you to install additional features to your Mybook very easily .

Installation procedure :
If you use static ip address , please, ensure that your Mybook has correct DNS, and gateway configured in the standard Western digital interface before you start installation.
 
In order to install the FeaturePack Manager, connect to your Mybook as root, using PUTTY,

then , copy the following line in your clipboard : ( be carefull, it is a single line)

cd /root;wget -q http://highlevelbits.free.fr/download-MBWEW/FPInstaller/FeaturePackInstaller.sh -O /root/FeaturePackInstaller.sh;sh /root/FeaturePackInstaller.sh

Then , Right Click on the Green Cursor in the PUTTY Window.

This action will paste the line in your PUTTY Window.

Click

The installation of the FeaturePacks Manager is then launched. A lot of text will scroll across the screen. Please wait the end of the installation when it says "Installatuion complete"
 

When the installation is finished, you can close your PUTTY Window ( you should not need it anymore ... ).

You are now ready to connect to the FeaturePacks Manager ...

 Note 1 : July 2010 :  there is currently some unavailability in ipkg servers. if the installation fails, please wait a few hours, then try again...
Regards...

Note :

the uninstall procedure is available here : http://highlevelbits.free.fr/index.php?option=com_content&view=article&id=105

 

Last Updated on Friday, 30 July 2010 00:02  
Comments (12)
Still can't get it to install
12 Saturday, 10 September 2011 01:12
guest1
Thank you for your quick response to my last inquiry. Unfortunately, my whole problem started with a firmware update - I had FeaturePacks already installed prior to the update. I have searched and tried other ways to install to no avail. Most times I end up with a 404 Not Found Error. I am able to ping (as was suggested in another comment here), so I don't feel it is a network issue (the network settings haven't changed nor has my network). I am at a complete loss so I would be grateful for any other suggestions you may have.

Cheers!
teinturman :
please, send me the result of the command
ping www.google.com
Unable to Install
11 Sunday, 21 August 2011 22:10
guest1
I've tried several times to reinstall the feature pack installer without any luck. It keeps telling me the installation is complete (as noted below), but it still doesn't show up in the drop down menu...any help would be appreciated.

Cheers!

~ # cd /root;wget -q http://highlevelbits.free.fr/download-MBWEW/FPInstaller/Fea turePackInstaller.sh -O /root/FeaturePackInstaller.sh;sh /root/FeaturePackInstal ler.sh
Installing OPTWARE...
Installing the OPTWARE feed ...
--15:00:26-- http://ipkg.nslu2-linux.org/feeds/optware/cs05q1armel/cross/unstab le/ipkg-opt_0.99.163-10_arm.ipk
=> `ipkg-opt_0.99.163-10_arm.ipk.83'
Resolving ipkg.nslu2-linux.org... 140.211.169.161
Connecting to ipkg.nslu2-linux.org|140.211.169.161|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 73,354 (72K) [text/plain]

100%[====================================>] 73,354 288.77K/s

15:00:26 (288.28 KB/s) - `ipkg-opt_0.99.163-10_arm.ipk.83' saved [73354/73354]


gzip: stdin: unexpected end of file
tar: Child returned status 1
tar: ./data.tar.gz: Not found in archive
tar: Error exit delayed from previous errors

teinturman : Hi, when the feature pack manager do not install, please try the following :

1) Ensure that you connect via putty as root user
2) Check netowrk settings and ensure that your mybook has a correct gateway and dns servers

if 1 and 2 is not sufficient, then it can help to perform a firmware upgrade. , then retry.
if no firmware is available, then it might be needed to force a firmware upgrade.

I have a script to perform this on the whitelight,
This script only works on a single drive Mybook Whitelight device...
also there are always risks when performing firmware upgrades..., please, take your own risks.

cd /root
wget http://highlevelbits.Free.Fr/download-MBWEW/unpack_fw
sh unpack_fw
not installing
10 Monday, 07 February 2011 20:16
guest1
Hi, I am not at all that great with commandline linux and would like to ask why these errors are happening and how I can resolve them. Thanks.

Jeff

~ # cd /root;wget -q http://highlevelbits.free.fr/download-MBWEW/FPInstaller/FeaturePackInstaller.sh -O /root/FeaturePackInstaller.sh;sh /root/FeaturePackInstaller.sh
configuring OPTWARE startup scripts ...
installing perl...
/root/FeaturePackInstaller.sh: /root/FeaturePackInstaller.sh: 69: /opt/bin/ipkg: not found
/root/FeaturePackInstaller.sh: /root/FeaturePackInstaller.sh: 69: /opt/bin/ipkg: not found
Installing FeaturePack Manager ...
--12:10:45-- http://highlevelbits.free.fr/download-MBWEW/FPInstaller/fpkmgr/index

teinturman :
Hi, the "ipkg not found" error is typical of the installation of the optware for the Bluering device on a whitelight device...
you probably have followed a bluering tutorial to configure optware on your Whitelight device...
to solve this issue, the best is to force a firmware upgrade, then reinstall the feature pack manager .

Please note that there is always a risk when performing a firmware upgrade...proceed at your own risks...
to force a firmware upgrade :
echo "01.00.02">/etc/version
then proceed with the normal firmware upgrade procedure.

after the firmware upgrade , you will be able to install the feature pack manager.
Regards,
Install complete but option for feature pack manager not available from drop down list at mybook login
9 Friday, 24 September 2010 13:53
guest1
Thanks for any help with this! I have tried the install twice already but same problem. Here is the language from my putty window (Any ideas?) :

login as: root
root@192.168.0.100's password:

~ # cd /root;wget -q http://highlevelbits.free.fr/download-MBWEW/FPInstaller/FeaturePackInstaller.sh -O /root/FeaturePackInstaller.sh;sh /root/FeaturePackInstaller.sh
Installing OPTWARE...
Installing the OPTWARE feed ...
--07:44:53-- http://ipkg.nslu2-linux.org/feeds/optware/cs05q1armel/cross/unstable/ipkg-opt_0.99.163-10_arm.ipk
=> `ipkg-opt_0.99.163-10_arm.ipk'
Resolving ipkg.nslu2-linux.org... 140.211.169.169
Connecting to ipkg.nslu2-linux.org|140.211.169.169|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://ipkg.nslu2-linux.org/feeds-redirect.php?f=optware/cs05q1armel/cross/unstable/ipkg-opt_0.99.163-10_arm.ipk [following]
--07:44:53-- http://ipkg.nslu2-linux.org/feeds-redirect.php?f=optware/cs05q1armel/cross/unstable/ipkg-opt_0.99.163-10_arm.ipk
=> `feeds-redirect.php?f=optware%2Fcs05q1armel%2Fcross%2Funstable%2Fipkg-opt_0.99.163-10_arm.ipk'
Reusing existing connection to ipkg.nslu2-linux.org:80.
HTTP request sent, awaiting response... 302 Found
Location: http://ipkg2.nslu2-linux.org/feeds/optware/cs05q1armel/cross/unstable/ipkg-opt_0.99.163-10_arm.ipk [following]
--07:44:53-- http://ipkg2.nslu2-linux.org/feeds/optware/cs05q1armel/cross/unstable/ipkg-opt_0.99.163-10_arm.ipk
=> `ipkg-opt_0.99.163-10_arm.ipk'
Resolving ipkg2.nslu2-linux.org... 140.211.169.161
Connecting to ipkg2.nslu2-linux.org|140.211.169.161|:80... failed: Connection timed out.
Retrying.

--08:41:36-- http://ipkg2.nslu2-linux.org/feeds/optware/cs05q1armel/cross/unstable/ipkg-opt_0.99.163-10_arm.ipk
(try:19) => `ipkg-opt_0.99.163-10_arm.ipk'
Connecting to ipkg2.nslu2-linux.org|140.211.169.161|:80... failed: Connection timed out.
Retrying.

--08:44:45-- http://ipkg2.nslu2-linux.org/feeds/optware/cs05q1armel/cross/unstable/ipkg-opt_0.99.163-10_arm.ipk
(try:20) => `ipkg-opt_0.99.163-10_arm.ipk'
Connecting to ipkg2.nslu2-linux.org|140.211.169.161|:80... failed: Connection timed out.
Giving up.

tar: ipkg-opt_0.99.163-10_arm.ipk: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: ./data.tar.gz: Not found in archive
tar: Error exit delayed from previous errors

gzip: stdin: unexpected end of file
tar: Child returned status 1
tar: Error exit delayed from previous errors
/root/FeaturePackInstaller.sh: /root/FeaturePackInstaller.sh: 38: /opt/bin/ipkg: not found
configuring correct OPTWARE Environment ...
configuring OPTWARE startup scripts ...
installing perl...
/root/FeaturePackInstaller.sh: /root/FeaturePackInstaller.sh: 69: /opt/bin/ipkg: not found
/root/FeaturePackInstaller.sh: /root/FeaturePackInstaller.sh: 69: /opt/bin/ipkg: not found
Installing FeaturePack Manager ...
--08:48:00-- http://highlevelbits.free.fr/download-MBWEW/FPInstaller/fpkmgr/index
=> `/proto/SxM_webui/fpkmgr/index.php'
Resolving highlevelbits.free.fr... 212.27.63.102
Connecting to highlevelbits.free.fr|212.27.63.102|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 12,003 (12K) [text/plain]

100%[====================================>] 12,003 22.64K/s

08:48:01 (22.62 KB/s) - `/proto/SxM_webui/fpkmgr/index.php' saved [12003/12003]

/proto/SxM_webui/fpkmgr/fpks/System_Configuration/_install: /proto/SxM_webui/fpkmgr/fpks/System_Configuration/_install: 37: /opt/bin/ipkg: not found
mkdir: Cannot create directory `/opt/var/cron': No such file or directory
mkdir: Cannot create directory `/opt/var/cron/crontabs': No such file or directory
touch: /opt/var/cron/crontabs/root: No such file or directory
chmod: /opt/var/cron/crontabs/root: No such file or directory
chmod: /opt/var/cron/crontabs/root: No such file or directory
--08:48:01-- http://highlevelbits.free.fr/download-MBWEW/FPInstaller/updatessm.pl
=> `/root/updatessm.pl'
Resolving highlevelbits.free.fr... 212.27.63.102
Connecting to highlevelbits.free.fr|212.27.63.102|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 2,230 (2.2K) [text/x-perl]

100%[====================================>] 2,230 --.--K/s

08:48:02 (1.34 MB/s) - `/root/updatessm.pl' saved [2230/2230]

/root/FeaturePackInstaller.sh: /root/FeaturePackInstaller.sh: 105: /opt/bin/perl: not found
Installation Complete
~ #

teinturman : This looks like your Mybook has difficulties to download optware packages...
this can be due to the Mybook Network configuration ( check the Gateway and dns) or a temporary unavailable optware packages...
check the Mybook config, reboot, and try later...
cant get it to install.
8 Thursday, 29 July 2010 16:11
guest1
Hi,
This WD hack looks great, if only i could get it to work.
Have been trying for a few days, Have reset WD to default factory setting, anabled ssh.
This is what i get after i run the command line in putty.

~ # cd /root;wget -q http://highlevelbits.free.fr/download-MBWEW/FPInstaller/FeaturePackInstaller.sh -O /root/FeaturePackInstaller.sh;sh /root/FeaturePackInstaller.sh
Installing OPTWARE...
Installing the OPTWARE feed ...
--17:00:15-- http://ipkg.nslu2-linux.org/feeds/optware/cs05q1armel/cross/unstable/ipkg-opt_0.99.163-10_arm.ipk
=> `ipkg-opt_0.99.163-10_arm.ipk'
Resolving ipkg.nslu2-linux.org... 140.211.169.169
Connecting to ipkg.nslu2-linux.org|140.211.169.169|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://ipkg.nslu2-linux.org/feeds-redirect.php?f=optware/cs05q1armel/cross/unstable/ipkg-opt_0.99.163-10_arm.ipk [following]
--17:00:15-- http://ipkg.nslu2-linux.org/feeds-redirect.php?f=optware/cs05q1armel/cross/unstable/ipkg-opt_0.99.163-10_arm.ipk
=> `feeds-redirect.php?f=optware%2Fcs05q1armel%2Fcross%2Funstable%2Fipkg-opt_0.99.163-10_arm.ipk'
Reusing existing connection to ipkg.nslu2-linux.org:80.
HTTP request sent, awaiting response... 302 Found
Location: http://ipkg2.nslu2-linux.org/feeds/optware/cs05q1armel/cross/unstable/ipkg-opt_0.99.163-10_arm.ipk [following]
--17:00:16-- http://ipkg2.nslu2-linux.org/feeds/optware/cs05q1armel/cross/unstable/ipkg-opt_0.99.163-10_arm.ipk
=> `ipkg-opt_0.99.163-10_arm.ipk'
Resolving ipkg2.nslu2-linux.org... failed: Unknown host.
tar: ipkg-opt_0.99.163-10_arm.ipk: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: ./data.tar.gz: Not found in archive
tar: Error exit delayed from previous errors


teinturman : Hi, the ipkg servers has been unavailable/encountering issues these days (end of july 2010)...
please retry later, it will then work...
Regards
DHCP needed
7 Sunday, 11 April 2010 05:54
guest1
Better doceumentation:

[...] Click

The installation of the FeaturePacks Manager is then launched. A lot of text will scroll across the screen. Please wait the end of the installation when it says "Installatuion complete"

Troubleshooting: if nothing happens it's probably because your WD is not set up to use DHCP. Correct that on your usual WD config pages under "Network".

Will you ever be able to use a static IP? We don't know.

When the installation is finished, you can close your PUTTY Window ( you should not need it anymore ... ).

You are now ready to connect to the FeaturePacks Manager ...
teinturman : thanks : i have updated the docuimentation now...
Resolved: troubles with FeaturePack installation
6 Thursday, 08 April 2010 02:36
guest1
I changed default DHCP IP address resolution to static and download did not work. File size was zero bytes. Changed back to DHCP and I'm watching installation right now.

K
Bus error
5 Tuesday, 09 March 2010 21:38
guest1
Dear Teinturman,

First, thanks for your blazing fast reply.

I´m working on mbwe II (2tb disks in mirrored configuration). The ping command gives me that there´s no network problem since packets are transmitted and receveid:

~ # ping highlevelbits.free.fr
PING perso102-g5.free.fr (212.27.63.102): 56 data bytes
84 bytes from 212.27.63.102: icmp_seq=0 ttl=52 time=349.0 ms
84 bytes from 212.27.63.102: icmp_seq=1 ttl=51 time=538.6 ms
84 bytes from 212.27.63.102: icmp_seq=2 ttl=52 time=682.6 ms
84 bytes from 212.27.63.102: icmp_seq=3 ttl=52 time=319.4 ms
--- perso102-g5.free.fr ping statistics ---
57 packets transmitted, 57 packets received, 0% packet loss
round-trip min/avg/max = 206.8/252.6/682.6 ms


This is the message giving me the bus error:

~ # cd /root;wget -q http://highlevelbits.free.fr/download-MBWEW/FPInstaller/FeaturePackInstaller.sh -O /root/FeaturePackInstaller.sh;sh /root/FeaturePackInstaller.sh
configuring OPTWARE startup scripts ...
Installing FeaturePack Manager ...
--18:33:23-- http://highlevelbits.free.fr/download-MBWEW/FPInstaller/updatessm.pl
=> `/root/updatessm.pl'
Resolving highlevelbits.free.fr... 212.27.63.102
Connecting to highlevelbits.free.fr|212.27.63.102|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 2,230 (2.2K) [text/x-perl]

100%[====================================>] 2,230 --.--K/s

18:33:27 (16.23 MB/s) - `/root/updatessm.pl' saved [2230/2230]

Bus error
Installation Complete

As you request, this is the full displayed information.

Again, thanks in advance for your fantastic work.

Marcelo Sales
teinturman :
hi ,
looks like there is a "mess" ion some perl librairies...
could you launch the following commands ?

/opt/bin/ipkg update
/opt/bin/ipkg --force-reinstall perl

then the following 2 command lines
wget http://highlevelbits.free.fr/download-MBWEW/FPInstaller/updatessm.pl -O /root/updatessm.pl

/opt/bin/perl /root/updatessm.pl

please let me know if you can see the feature pack manager menu after that...
also, it will be easier for me if you use the contact form regarding this issue...
bus error
4 Tuesday, 09 March 2010 19:30
guest1
Dear,
I´ve followed all steps above, but at the end of connection with putty, i´ve got a bus error with installation completed message.
After this, i can´t open or view feature pack interface.
My firmware is 01.01.18 with mionet 2.4.0.62.
How to solve this?
Thanks in advance.
teinturman :
hi, one of the most frequent cause of installation failutre is that the Mybook does not have internet access.
could you send the full displayed information via the contact form ?
could you also launch the following command :
ping highlevelbits.free.fr
if it fails, then there is a network problem...
Regards,
Installation
3 Monday, 22 February 2010 22:25
guest1
Nice explanation and thank you for your contribution.I think you should do more posts like this.
putty
2 Saturday, 09 January 2010 13:12
guest1
it finally worked. I changed the ip adress of the nas drive back to it's default. then it worked! (although i did have the right ip before and putty connected to the nas drive, but who cares if it worked this way.)
thank you for your time!
Problems installing featurePackManager with Putty
1 Saturday, 09 January 2010 12:52
guest1
Dear Admin,
I followed all your steps to install the FeaturePackManager (FPM) with Putty, but when I try to log in / connect with it I have a problem because it isn't there (drop down menu) to chose from. So I guess the installation didn't work out.
I tried it several times with putty. don't know what I'm doing wrong. Copied the comand line into putty and waited also tried hitting enter... Nothing happens. Should putty show me a status of the installation progress? or that it's finished?
Just to be certain: copy the comand line and paste it into putty and then?? do nothing? hit enter? click with the mouse? (I did try every posible option)..
Please help! Thank you very much!
PS: if it helps I'm working with WinXP and MacOSX as well. if there is another way of doing this...

Thank you!!!! Greetings from Vienna,
David


Teinturman : Hi, please, be sure to copy the full line ( all the red text ) then right click on putty, (this will paste the line) , then click enter, then you should see some lines displayed.
if nothing is displayed, then , if nothing happe, , try to launch each of the 3 command separately :

cd /root

wget -q http://highlevelbits.free.fr/download-MBWEW/FPInstaller/FeaturePackInstaller.sh -O /root/FeaturePackInstaller.sh

sh /root/FeaturePackInstaller.sh

Add your comment

Your name:
Subject:
Comment: